Gérer (facilement !) plusieurs install de ruby

rvm-noir

Votre Apple flambant neuf sort du carton, et vous voulez installer ruby ?
Rien à faire, avec mac OS X, vous avez une installation par défaut de ruby.
Tapez dans un terminal :

[sourcecode]
$ ruby -v
ruby 1.8.7 (2008-08-11 patchlevel 72) [universal-darwin10.0]
[/sourcecode]

gem (le gestionnaire standard de packages ruby) est déjà dispo :
[sourcecode]
$ gem -v
1.3.1
[/sourcecode]

Mais vous voulez essayer ruby 1.9, tout en vous laissant le choix de passer d’une version de ruby à une autre. Comment faire ?
C’est simple avec rvm
Lire la suite